How It Works Start My Diary Login Sign Up
NattyStateGrower started grow question 3 years ago
It's the end of week2 and I have no real sign if pre flowers. I've never come across this before so im not sure if it's abnormal and if it is what can I do if there is anything to do? Any help is appreciated :+1::facepunch::man-bowing:.
Gelat O.G.- Seedsman
9 weeks
Gelat O.G.- Seedsman NattyStateGrower
Gelat.OG
33 comments · 3 years ago
Resolved
Week 6
Techniques. Defoliation
Stick answered grow question 3 years ago
Hi @NattyStateGrower! Looking at day 43, I can see signs of preflowers. If you're confident you didn't have a light-leak or a timer issue, then it's probably genetics-related. Let's see how these bud sites will expand into beautiful flowers! Keep us updated, and happy growing :facepunch:
GreenHouseLab answered grow question 3 years ago
Give it time, I see you introduced bloom fertilizer it should also help to kick start but if your light cycle is correct as mentioned it's sometime normal for it to take a week or two. Just be happy your plant is looking solid! :ok_hand::muscle:
DissNoof answered grow question 3 years ago
CONGRATULATIONS ! It's a girl !
DILLIGAF answered grow question 3 years ago
Hi there mate Athos and longjohn could well be right however there are two other possible reasons for your plants
not shifting into flower yet.
They are #1 is your timer set correctly? are you certain they are getting atleast 12 hours of uninterupted darkness?
#2 is a possible light leak within your tent. Something as simple as a red light on a powerboard (trust me Ive had it happen)
could be enough to confuse your plants and keep them in veg mode Zip yourself after lights out and see if its completely dark
Hope Ive helped somewhat :smiley: best of luck
Removed answered grow question 3 years ago
I've had that happen on strains that show a more sativa like phenotype, they can take up to 4 weeks to show preflowers; I would not worry. Do try to keep the stretch controlled.
LongJohn420 answered grow question 3 years ago
Hi there! I think you have gave her too Nitrogen after switching to 12/12 that may cause flowering to take time to start. Get off you grow nutes maybe change water with less grow ( nitrogen ) in your reservoir. You are growing in hydro setup aren't you?
Also recovering from training could postpone flowering period a bit.
Hope this helps and happy growing! Looking good!